Missing-partition-for-run-step error in Synchronization Service Manager after deploying Azure AD Connect ?

This happens in a scenario where you have multiple domains but choose not to synchronize one. Even though nothing is being synchronized the configuration wizard still adds a step in the run profiles to try and synchronize which causes the error. The solution is to remove the step from the run profiles using Synchronization Service Manager as follows:

  1. Launch the Synchronization Service Manager (C:\Program Files\Microsoft Azure AD Sync\UIShell\miisclient.exe)
  2. In the Operations tab you will notice the errors related to “missing-partition-for-run-step”
  3. Select the Connectors tab
  4. Right-click the management agent or the Connector type for Active Directory Domain Services, and then click Configure Run Profiles
  5. Right click on your on-premises Active Directory connector and select Configure Run Profiles action
  6. Look for the step that has a Partition value that contains a string of alphanumeric characters (for example, {19C9A43A-8F9C-897D-97B9-F0158934D691}), and then click Delete Step
  7. Click Apply and then click OK
  8. Repeat the steps from 6-7 for each run profiles
  9. Right click the same management agent or connector again and then click RUN
  10. Select Full Sync and then click OK
Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s